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SUMMARY

The project implements a full-featured chat application in the form of a fault tolerant and voice

, enabled system. The client and server services operate over a modularized WINDOWS OS network
architecture. In addition, this application infers the occurrence of client communication with the
connected peers and the server itself via Ethernet Lan and VOIP. It thus provides a network with an
advanced functionality of communication which is both user friendly and hassle free. The rules
implemented allow efficient communication and broaden the scope of a simple Ethernet connection
by enabling transfer of voice data packets over it.

Signature: Signature:
Name; Name:
Date: Date:




\ LIST OF FIGURES

(RSB 3 TN

Figure Number Figure Name Page NO.
Fig 1 | Client Server Architecture 5
Fig2 Two tier Architecture 6
Fig3 Three tier Architecture 7
Fig 4 N Tier Architecture 9
Fig 5 Netbeans New Project 15
Fig 6 Netbeans New project 11 16
Fig 7 Netbeans Main Project 17

Window
Fig 8 | Project Execution Window 18
Fig9 Command Prompt 24
Window
Fig 10 | Apache Ant Home Screen 27




r

V1

||[LIST OF ABBREVIATIONS AND SYMBOLS

* TCP: Transfer Centrol Protocol

UDP: User Datagram Protocol




L CHAPTER 1

1.1 INTRODUCTION TO NETWORKING :

A network is simply a collection of computers or other hardware devices that are connected
together, either physically or logically, using special hardware and software, to allow them to
exchange information and cooperate. Networking is the term that describes the processes involved
in designing, implementing, upgrading, managing and otherwise working with networks and

network technologies.

Networks are used for an incredible array of different purposes. In fact, the definitions above
are so simple for the specific reason that networks can be used so broadly, and can allow such a

wide variety of tasks to be accomplished.

The widespread networking of personal computers is a relatively new phenomenon. For the
first decade or so of their existence, PCs were very much “islands unto themselves”, and were rarely
connected together. In the early 1990s, PC networking began to grow in popularity as businesses
realized the advantages that networking could provide. By the late 1990s, networking in homes with

two or more PCs started to really take off as well.

This interconnection of small devices represents, in a way, a return to the “good old days” of
mainframe computers. Before computers were small and personal, they were large and centralized
machines that were shared by many users operating remote terminals. While having the entire
computer power in one place had many disadvantages, one benefit was that all users were

connected because they shared the central computer.

Individualized PCs took away that advantage, in favor of the benefits of independence.
Networking attempts to move computing into the middle ground, providing PC users with the best
of both worlds: the independence and flexibility of personal computers, and the connectivity and
resource sharing of mainframes. in fact, networking is today considered so vital that it’s hard to
conceive of an organization with two or more computers that would not want to connect them

together,

—




The advantages of networking include:

g
i
!

> Connectivity and Communication:

Networks connect computers and the users of those computers. Individuals within a
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building or work group can be connected into local area networks (LANs); LANSs in distant
locations can be interconnected into larger wide area networks (WANs). Once connected, it
is possible for network users to communicate with each other using technologies such as
electronic mail. This makes the transmission of business (or non-business) information

easier, more efficient and less expensive than it would be without the network.

> Data Sharing:

One of the most important uses of networking is to allow the sharing of data. Before
networking was common, an accounting employee who wanted to prepare a report for her
manager would have to produce it on his PC, put it on a floppy disk, and then walk it over to

the manager, who would transfer the data to her PC's hard disk.

True networking allows thousands of employees to share data much more easily and quickly
than this. More so, it makes possible applications that rely on the ability of many people to
access and share the same data, such as databases, group software development, and much
more. Intranets and extranets can be used to distribute corporate information between sites

and to business partners.
> Hardware Sharing:

Networks facilitate the sharing of hardware devices. For example, instead of giving each of
10 employees in a department an expensive color printer one printer can be placed on the

‘ network for everyone to share.




Internet Access:

The Internet is itself an enormous network, so whenever you access the Internet, you are
using a network. The significance of the Internet on modern society is hard to exaggerate,

especially for those of us in technical ficlds.
Internet Access Sharing:

Small computer networks allow multiple users to share a single Internet connection. Special
hardware devices allow the bandwidth of the connection to be easily allocated to various
individuals as they need it, and permit an organization to purchase one high-speed

connection instead of many slower ones.
Data Security and Management:

In a business environment, a network allows the administrators to much better manage the
company's critical data. Instead of having this data spread over dozens or even hundreds of
small computers in a haphazard fashion as their users create it, data can be centralized on
shared servers. This makes it easy for everyone to find the data, makes it possible for the
administrators to ensure that the data is regularly backed up, and also allows for the
implementation of security measures to control that can read or change various pieces of

critical information.
Performance Enhancement and Balancing:

Under some circumstances, a network can be used to enhance the overall performance of

some applications by distributing the computation tasks to various computers on the

network.




"I

12 INTRODUCTION TO THE CLIENT SERVER MODEL.:

Client/server model is a concept for describing communications between computing processes that
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are classified as service consumers (clients) and service providers (servers). The basic features of a

/S model are:

» Clients and servers are functional modules with well defined interfaces (i.e., they hide
internal information). The functions performed by a client and a server can be implemented
by a set of software modules, hardware components, or a combination thereof. Clients

and/or servers may run on dedicated machines, if needed.

» Each client/server relationship is established between two functional modules when one
module (client) initiates a service request and the other (server) chooses to respond to the

fn

service request. Examples of service requests (SRs) are "retrieve customer name," "produce
net income in last year," etc. For a given service request, clients and servers do not reverse
roles (i.e., a client stays a client and a server stays a server). However, a server for SR R1
may become a client for SR R2 when it issues requests to another .For example, a client may

issue an SR that may generate other SRs.

» Information exchange between clients and servers is strictly through messages (i.e., no
information is exchanged through global variables). The service request and additional
information is placed into a message that is sent to the server. The server's response is
similarly another message that is sent back to the client. This is an extremely crucial feature

of C/S model.

» Messages exchanged are typically interactive. In other words, C/S model does not support
an off-line process. There are a few exceptions. For example, message queuing systems
allow clients to store messages on a queue to be picked up asynchronously by the servers at

a later stage.

» Clients and servers typically reside on separate machines connected through a network.
Conceptually, clients and servers may run on the same machine or on separate machines. In
this book, however, our primary interest is in distributed client/server systems where clients

and servers reside on separate machines.




The implication of the last two features is that C/S service requests are real-time messages that are
exchanged through network services. This feature increases the appeal of the C/S model (i.e.,

flexibility, scalability) but introduces several technical issues such as portability, interoperability,

~ security, and performance.
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Fig 1: Client Server Communication




CHAPTER 2

¢ 91 Different Types of Client Server Architectures:
Firewalls fall into three broad categories: Two Tier Architecture, Three Tier Architecture
and N Tier Architecture.

2.1.1 Two Tier Architecture:

In this implementation, the three components of an application (presentation, processing, and data)

are divided among two software entities (tiers): client application code and database server,

Raquest (usually S0L)

- Rasult (data)
=

Client Setver

Figure 2. Two Tier Architecture

Presentation is handled exclusively by the client, processing is split between client and server, and

. data is stored on and accessed via the server. The PC client assumes the bulk of responsibility for

application (functionality) logic with respect to the processing component, while the database

: engine - with its attendant integrity checks, query capabilities and central repository functions -

handles data intensive tasks.

Two-tier architectures work well in relatively homogeneous environments with fairly static

. business rules. However this architecture is less suited for dispersed, heterogeneous environments

~ with rapidly changing rules.




2.1.2 Three Tier Architecture:

The tree tier architecture attempts to overcome some of the limitations of the two-tier scheme

by separating presentation, processing, and data into separate, distinct software entities (tiers).
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Figure 3. Three Tier Architecture

When calculations or data access is required by the presentation client, a call is made to a middle
tier functionality server. This tier can perform calculations or can make requests as a client to
additional servers. Middle-tier functionality servers may be multi-threaded and can be accessed by

i multiple clients, even those from separate applications.

' The calling mechanism from client to server in such as system is most typically the remote

" procedure call or RPC. In an RPC, the requesting client passes the parameters needed for the
request and specifies a data structure to accept returned values.

. The three tier architecture provides for more flexible resource allocation. Middle-tier functionality
servers are highly portable and can be dynamically allocated and shifted as the needs of the
organization change. Network traffic can potentially be reduced by having functionality servers

| strip data to the precise structure required before distributing it to individual clients at the LAN

- level. Multiple server requests and complex data access can emanate from the middle tier instead of

. the client, further decreasing traffic.




§ 2.1.3 N Tier Architecture :
Usually N-Tier Architecture begins as a 3-Tier model and is expanded. It provides finer
granularity. Granularity is the ability of a system, in this case, an application, to be broken down
into smaller components or granules. The finer the granularity,the greater the flexibility of a

g system. It can also be referred to as a system’s modularity. Therefore, it refers to the pulling

apart of an application into separate layers or finer grains. One of the best examples of N-Tier

#

lg .
i Architecture in web applications is the popular shopping-cart web application. The client tier
interacts with the user through GUIs (Graphic User Interfaces) and with the application and the

application server. In web applications, this client tier is a web browser. In addition to initiating

Bl meeh

the request, the web browser also receives and displays code in dynamic HTML (Hypertext
Markup Language), the primary language of the World Wide Web. In a shopping cart web
application, the presentation tier displays information related to such services as browsing
merchandise, purchasing, and shopping cart contents. It communicates with other tiers by

outputting results to the browser/client tier and all other tiers in the network. This layer calls

o AL VY £ ARGADE T T e v

custom tags throughout the network and to other networks. It also calls database stored
procedures and web services, all in the goal of providing a more sophisticated response. This
layer glues the whole application together and allows different nodes to communicate with each
other and be displayed to the user through the browser. It is located in the application server. In
N-Tier Architecture, the business logic tier is pulled out from the presentation tier and, as its
own layer; it controls an application’s functionality by performing detailed processing. For
example, in our shopping cart example, this tier completes credit card authorization and
calculates things like shipping costs and sales tax. The tools used to encapsulate an application’s
business logic into its own layer include web services, custom tags, and stored procedures. The
business tier can also be considered the integration layer. Encapsulation allows the application
to communicate with the data tier or the business logic tier in a way that is intelligible to all
nodes. Encapsulation is one of the principles of object-oriented programming (OOP) and refers
to an object’s ability to conceal its data and methods. Encapsulated objects only publish the
external interface so any user interacting with them only needs to understand the interface and
can remain ignorant as to the internal specifications. This way a user can call all sorts of
! services into action by calling the custom tag without having to know the code details of what
made communication or implementation possible. The services just have to be accessible in the
custom tag library. Encapsulation in the integration tier also liberates the network from just one
vendor. The integration tier allows N-Tier Architecture to be vendor independent. In the

shopping cart example, the application may have a simple custom tag for searching inventory
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and providing the most up-to-date, detailed information. The final application tier is the data
g tier. It usually consists of database servers. It keeps data neutral and independent from
application servers or business logic. Giving data its own tier also improves scalability and

performance. As it grows, it is easily moved to another, more powerful machine.

; Web
: ser
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.
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Fig 4: N Tier Architecture

2.1.3.1 Bencefits of N Tier Architecture

There are many business benefits to N-Tier Architecture. For example, a small business can
begin running all tiers on a single machine. As traffic and business increases, each tier can be
expanded and moved to its own machine and then clustered. This is just one example of how N-
Tier Architecture improves scalability and supports cost-efficient application building. N-Tier
model also make applications more readable and reusable. It reduces the amount of spaghetti
z code. Custom tag libraries and EJBs are easier to port to readable applications in well-
| maintained templates. Reusability multiplies developer productivity and improves application
maintainability. It is an important feature in web applications. N-Tier Architectures make
application more robust because there is no single point of failure. Tiers function with relative
independence. For example, if a business changes database vendors, they just have to replace
the data tier and adjust the integration tier to any changes that affect it. The business logic tier

and the presentation tier remain unchanged. Likewise, if the presentation layer changes, this
9




wﬂl not affect the integration or data layer. In 3-Tier Architecture all the layers exist in one and
affect each other. A developer would have to pick through the entire application code to
implement any changes. Again, well-designed modules allow for applications or pieces of
applications to be customized and used across modules or even projects. Reusability is
particularly important in web applications. As demonstrated N-Tier Architecture offers
innovations in the standard Client-Server technology that spawned the Internet itself. It is but
one of many web application frameworks. These are used to develop dynamic web sites, web
applications or web services. They provide database access libraries, templates, and, as
previously stated code re-use. Most web application frameworks follow the Model View
Controller (MVC) which separate the user interface, the business rules and the data model.
They provide authentication and authorization to provide security. This allows the web server to
restrict user access based on pre-determined criteria. Web application frameworks also provide

a unified API (Apptlication programming Interface). This allows web application to work with

s i wles s e m e i s e et
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various databases without requiring any code change. These frameworks also maintain a web
template system. Finally, N-Tier Architecture helps developers build web applications because
it allows developers to apply their specific skill to that part of the program that best suits their
skill set. Graphic artists can focus on the presentation tier, while administrators can focus on the

database tier.

2.1.4 Comparison with P2P model for Communication

Peer-to-peer networks are typically less secure than client-server networks because security is
handled by the individual computers, not on the network as a whole. The resources of the computers
in the network can become overburdened as they have to support not only the workstation user, but
. also the requests from network users. It is also difficult to provide system wide services because the
. desktop operating system typically used in this type of network is incapable of hosting the service.
Where the client-server networks have a higher initial setup cost. It is possible to set up a server on
. adesktop computer, but it is recommended that businesses invest in enterprise-class hardware and
- software. They also require a greater level of expertise to configure and manage the server hardware

and software,

10
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Client Server A rchitecture:

1. A client-server network involves multiple clients connecting to a single, central server. The

file server on a client-server network is a high capacity, high speed computer with a large

e g el

i hard disk capacity.
5. A client-server model works with any size or physical layout of LAN and doesn't tend to

slow down with a heavy use.

Peer-to-Peer Mode!

1. Peer-to-peer networks involve two or more computers pooling individual resources such as

Rkl e o ord e i Sre S

disk drives, CD-ROMs and printers. These shared resources are available to every computer

in the network. Each computer acts as both the client and the server which means all the
computers on the network are equals, that is where the term peer-to-peer comes from.

2. In the peer to peer network, software applications can be installed on the single computer

and shared by every computer in the network. They are also cheaper to set up because most

desktop operating systems have the software required for the network installed by default.

e .

} 2.2 Paradigms Used In Client Server’Architectures

2.2.1 Remote Procedure Call (RPC).

In this paradigm, the client process invokes a remotely located procedure (a server
process), the remote procedure executes and sends the response back to the client. The
remote procedure can be simple (e.g., retrieve time of day) or complex (e.g., retrieve all
customers from Chicago who have a good credit rating). Each request/response of an
RPC is treated as a separate unit of work, thus each request must carry enough

information needed by the server process. RPCs are supported widely at present.

il
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2.2.2 Remote Data Access (RDA).

This paradigm allows client programs and/or end-user tools to issue ad hoc queries,
usually SQL, against remotely located databases. The key technical difference between
RDA and RPC is that in an RDA the size of the result is not known because the result
of an SQL query could be one row or thousands of rows. RDA is heavily supported by

database vendors.

2.2.3 Queued Message Processing (QMP)

In this paradigm, the client message is stored in a queue and the server works on it
when free. The server stores ("puts") the response in another queue and the client actively retrieves
("gets") the responses from this queue. This model, used in many transaction processing systems,
allows the clients to asynchronously send requests to the server. Once a request is queued, the
request is processed even if the sender is disconnected (intentionally or due to a failure). QMP
support is becoming commonly available.

Initial implementations of client/server architecture were based on the "two-tiered”

architectures shown in Figure (a) through Figure (e) (these architectural configurations are known

as the "Gartner Group" configurations). The first two architectures (Figure (a) and Figure (b) are

used in many presentation intensive applications (e.g., XWindow, multimedia presentations) and to
provide a "face lift" to legacy applications by building a GUI interface that invokes the older text-
based user interfaces of legacy applications. Figure (c) represents the distributed application
program architecture in which the application programs are split between the client and server

machines, and they communicate with each other through the remote procedure call (RPC) or

. queued messaging middleware. Figure (d) represents the remote data architecture in which the

remote data is typically stored in a "SQL server" and is accessed through ad hoc SQL statements

- sent over the network.

12
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1.3 Protocols used in Client Server Architecture

2.3.1 UDP

The UDP protocol provides for communication that is not guaranteed between two applications on
the network. UDP is not connection-based like TCP. Rather, it sends independent packets of data,
called datagram, from one application to another. Sending datagram is much like sending a letter
through the postal service: The order of delivery is not important and is not guaranteed, and each

message is independent of any other.

For many applications, the guarantee of reliability is critical to the success of the transfer of
information from one end of the connection to the other. However, other forms of communication
don't require such strict standards. In fact, they may be slowed down by the extra overhead or the

reliable connection may invalidate the service altogether.

Consider, for example, a clock server that sends the current time to its client when requested to do
so. If the client misses a packet, it doesn't really make sense to resend it because the time will be
incorrect when the client receives it on the second try. If the client makes two requests and receives
packets from the server out of order, it doesn't really matter because the client can figure out that the
packets are out of order and make another request. The reliability of TCP is unnecessary in this

instance because it causes performance degradation and may hinder the usefulness of the service.

Another example of a service that doesn't need the guarantee of a reliable channel is the ping
command. The purpose of the ping command is to test the communication between two programs
over the network. In fact, ping needs to know about dropped or out-of-order packets to determine
how good or bad the connection is. A reliable channel would invalidate this service altogether. The
UDP protocol provides for commuhication that is not guaranteed between two applications on the

network, UDP is not connection-based like TCP.

Rather, it sends independent packets of data from one application to another. Sending datagram is

much like sending a letter through the mail service: The order of delivery is not important and is not

. Buaranteed, and each message is independent of any others.

13




23.2 TCP

When two applications want to communicate to each other reliably, they establish a
connection and send data back and forth over that connection. This is analogous to
making a telephone call. If you want to speak to Aunt Beatrice in Kentucky, a

connection is established when you dial her phone number and she answers. You send

data back and forth over the connection by speaking to one another over the phone lines.
i Like the phone company, TCP guarantees that data sent from one end of the connection
i actually gets to the other end and in the same order it was sent. Otherwise, an error is
reported. TCP provides a point-to-point channel for applications that require reliable
communications. The Hypertext Transfer Protocol (HTTP), File Transfer Protocol
i (FTP), and Telnet are all examples of applications that require a reliable communication

E channel. The order in which the data is sent and received over the network is critical to

L the success of these applications. When HTTP is used to read from a URL, the data must

i be received in the order in which it was sent.

14




CHAPTER 3

3.1Setting up the Project
To create an IDE project:

1. Start NetBeans IDE.

2. In the IDE, choose File > New Project (Ctrl-Shifi-N), as shown in the figure below.

¢ NetBeans IDF 6.9 RC2

iew Na}iigate _Source  Refactor

r—— - CtrkeshiftH
n Mew File. ..
Open Project... Ctrl+Shift+0
COpen Recent Project b

Open Team Project...

3. In the New Project wizard, expand the Java category and select Java Application as shown

in the figure below. Then click Next.

# New Project

Steps Choose Project

1. Choose Project Categories: Projects:
53 JavaWeb

ilﬁﬁ JavaEE

B JavaME

L2 Maven

E‘,‘; Groovy

? L-[23 NetBeans Modules
-0 samples

A% JavaFree-Form Project

PO

Description:

Creates a new Java SE application in a standard IDE
project. You can also generate a main class in the project.
Standard projects use an IDE-generated Ant build

e i S it

[ Cancel | rHéhﬁ ]

Fig 5: NetBeans New Project

v

4. In the Name and Location page of the wizard, do the following (as shown in the figure
below):




"+ In the Project Name field, type project name.
e Leave the Use Dedicated Folder for Storing Libraries checkbox unselected.

o In the Create Main Class field, type the main class name.

o Leave the Set as Main Project checkbox selected.

P New Java Application

steps Nélfl't_: and Location .

{, Choose Project ) P rojé d: Name: lHelloWorldApp |
2. Name and Location _

Project Location: '[C:\work‘l,tmptnbpruj ] rErowse... ]

Projﬁ;t Folder: ic:1wnrk\,tmp\ribproj'l,HeIanorldA;}

[ Use Dedicated Folder for Storing Libraries

. . i T
Libraries ?e!dér:l ]H Browse,.. |

Different users and projects
can share the same compilation
libraries {sea Help For details).

Create Main Class | helloworldapp.HelloworldApp] }
Set as Main Project

_____ (o) (e ) ()

TR RN
A
o
["1]
(m]
o
=

Fig 6: Netbeans New Project 11
5. Click Finish.

The project is created and opened in the IDE. You should see the following components:

—

Lo e P o Py
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+ The Projects window, which contains a tree view of the components of the project, including

source files, libraries that your code depends on, and so on.
i + The Source Editor window with a file called project name open.

 The Navigator window, which you can use to quickly navigate between elements within the

f selected class.

4 » The Tasks window, which lists compilation etrors as well other tasks that are marked with

: keywords such as XXX and TODO.

16
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Fig 7: new project main window 1

3.2 Adding Code to the Generated Source File

Because you have left the Create Main Class checkbox selected in the New Project wizard, the IDE
~ has created a skeleton main class for you. You can add the "Hello World!" message to the skeleton

code by replacing the line:

// TODO code application logic here

with the line:

System.out.println("Hello World!");

Save the change by choosing File > Save.

17




3.3 Cbmpil'mg and Running the Program
Because of the IDE's Compile on Save feature, you do not have to manually compile your project in
order to run it in the IDE. When you save a Java source file, the IDE automatically compiles it.
The Compile on Save feature can be turned off in the Project Properties window. Right-click your
project, select Properties. In th.e Properties window, choose the Compiling tab. The Compile on
Save checkbox is right at the top. Note that in the Project Properties window you can configure
] numerous settings for your project; project libraries, packaging, building, running, etc..
4 To run the program:
« Choose Run > Run Main Project (F6).

The next figure shows what you should now see.

“Autput - HelloworldApp (run) % x[iTasks

M@ ~1
o RVl

8%

Fig 8: Program Execution window

If there are compilation errors, they are marked with red glyphs in the left and right margins of the
Source Editor. The glyphs in the left margin indicate errors for the corresponding lines. The glyphs
in the right margin show all of the areas of the file that have errors, including errors in lines that are
i§ not visible. You can mouse over an error mark to get a description of the error. You can click a

It glyph in the right margin to jump to the line with the error.

i34 Building and Deploying the Application

. Once you have written and test runs your application, you can use the Clean and Build command to

P

build your application for deployment. When you use the Clean and Build command, the IDE runs a

e

build script that performs the following tasks:

b v

* Deletes any previously compiled files and other build outputs.

* Recompiles the application and builds a JAR file containing the compiled files.

L e v R T— s

To build your application:

* Choose Run > Clean and Build Main Project (Shift-F11)

D et ta el L
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3.4 Project Setup

. The application you create will contain two projects:

« A Java Class Library project in which you will create a utility class.

. A Java Application project with a main class that implements a method from the library

project's utility class.
After you create the projects, you will add the library project to the classpath of the application
project. Then you will code the application. The library project will contain a utility class with
f an acrostic method. The acrostic method takes an array of words as a parameter and then generates
an acrostic based on those words. The MyApp project will contain a main class that calls
the acrostic method and passes the words that are entered as arguments when the application is run.
3.4.1 Creating a Java Class Library Project
1. Choose File > New Project (Ctrl-Shift-N). Under Categories, select Java. Under Projects,
select Java Class Library. Click Next.

2. Under Project Name, type MyLib. Change the Project Location to any directory on your

computer. From now on, this tutorial refers to this directory as NetBeans_projects.

é
,5. 3. (Optional) Select the Use Dedicated Folder for Storing Libraries checkbox and specify the

location for the libraries folder. See Sharing Project Libraries for more information on this l

option.
4. Click Finish. The MyLib project opens in both the Projects window and the Files window.
i 3.4.2 Creating a Java Application Project

i 1. Choose File > New Project. Under Categories, select Java. Under Projects, select Java

Application. Click Next.

f 2. Under Project Name, type MyApp. Make sure the Project Location is set

to NetBeans_projects.

3. (Optional) Check the Use Dedicated Folder for Storing Libraries checkbox.

£ 4. Enter acrostic.Main as the main class.

5. Ensure that the Set as Main Project and Create Main Class checkboxes are checked.

6. Click Finish. The MyApp project is displayed in the Project window and Main. java opens in

the Source Editor.
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3.4.3 Configuring the Compilation Classpath

Since MyApp is going to depend on a class in MyLib, you have to add MyLib to the classpath of
MyApp. Doing so also ensures that classes in the MyApp project can refer to classes in the MyLib

project without causing compilation errors. In addition, this enables you to use code completion in

1 the MyApp project to fill in code based on the MyLib project. In the IDE, the classpath is visually

represented by the Libraries node.
To add the library's utility classes to the project classpath:
1. In the Projects window, right-click the Libraries node for the MyApp project and choose
Add Project as shown in the image below.

g-& MyApp

E E% Source Packages

Add Project..

[ mfB Testlbi  Add Librarv...

2. Browse to NetBeans projects/ and select the MyLib project folder. The Project JAR Files
pane shows the JAR files that can be added to the project. Notice that a JAR file for MyLib

is listed even though you have not actually built the JAR file yet. This JAR file will get built
when you build and run the MyApp project.

3. Click Add Project JAR Files.

4. Expand the Libraries node. The MyLib project's JAR file is added to the MyApp project's
classpath.

3.4.4 Creating and Editing Java Source Code

Now you need to create a Java package and add the method that you will use to construct the

acrostic. After that you need to implement the acrostic method in the Main class.

34.4.1 Creating a Java Package and Class File

1. Right-click the MyLib project node and choose New > Java Class. Type LibClass as the
name for the new class, typeorg.me.mylibin the Package field, and click

Finish. LibClass.java opens in the Source Editor.

. InLibClass.java, place the cursor on the line after the class declaration (public class
LibClass {.

3. Type or paste in the method code.

20
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4. If the code that you pasted in is not formatted correctly, press Alt-Shift-F to reformat the
entire file.

5. Press Ctrl-S to save the file.

bp‘g&n }]Q\
" 3 '?Qh.']{‘ Solan \
) 3.4.4.2 To add the arguments for the IDE to use when running the applicatiom

1. Right-click the MyApp project node, choose Properties, and select the Run node in the
dialog's left pane.
The main class should already be set to acrostic.Main.
2. Type However we all feel zealous in the Arguments field and click OK.
Running the Application

Now that you have created the application and provided runtime arguments for the application, you

can test run the application in the IDE.

3.4.5 To run the application in the IDE: !

o Choose Run > Run Main Project (F6).

In the Output window, you should see the output from the program, Result = Hello (the acrostic of

the phrase that was passed to the program as an argument).

Testing and Debugging the Application

Now you will create and run a test for the project using JUnit and then run the application in the
IDE's debugger to check for errors. In the JUnit test, you will test the LibClass by passing a phrase

to the acrostic method and using an assertion to indicate what you think the result should be.

3.5 Creating JUnit Tests

1. Right-click the LibClass.java node in the Projects window and choose Tools >Create JUnit

Tests (Ctrl-Shift-U).

If this is the first time you have created JUnit tests in the IDE, you will be prompted with the Select

JUnit Version dialog box. Press Enter to select JUnit 4.x and continue to the Create Tests dialog

box.
2. In the Create Tests dialog box, click OK to run the command with the default options. The
IDE creates theorg.me.mylib package and the LibClassTest.java file in a separate test folder.
You can find this file by expanding the Test Packages node and the org.me.mylib subnode.

3. In LibClassTest.java, delete the body of the public void testAcrostic() method.
21
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4. Inplace of the deleted lines, type or paste in the following:
5. System.err.println("Running testAcrostic...");
6. String result = LibClass.acrostic(new String[]

7. {"fnord", "polly", "tropism" });

assertEquals("Correct value", "foo", result);

ey G B B AT,

8. Save the file by pressing Ctrl-S.

!i 3.6 Running JUnit Tests
; 1. Select the MyLib project node and choose Run > Test Project (MyLib) or press Alt-F6.

i The MyLib (test) tab opens in the Output window. The JUnit test cases are compiled and

i run. The JUnit test result shows that the test passes.

! 7. You can also run a single test file rather than testing the entire project. Select

the LibClass.java tab in the Source Editor and choose Run > Test File.

137 Debugging the Application

8 1. In the LibClass.java file, go to the acrostic method and place the insertion point anywhere

‘E insideb.append(args[i].charAt(i));. Then press Ctrl-F8 to sct a breakpoint.
] 2. Choose Debug > Debug Main Project (Ctrl-F5). The IDE opens the Debugger windows and T
/ runs the project in the debugger until the breakpoint is reached.
# 3. Select the Local Variables window in the bottom of the IDE and expand the args node. The
i array of strings contains the phrase you entered as the command arguments.
4. Press F7 (or choose Debug > Step Into) to step through the program and watch
i the b variable change as the acrostic is constructed.

} When the program reaches the end, the debugger windows closes.

3.8 Building, Running, and Distributing the Application

#
i
-
#

=

Once you are satisfied that your application works properly, you can prepare the application for

R

i deployment outside of the IDE. In this section you will build the application’s JAR file and then run

- i
)

1 the JAR file from the command line. l

s

AT T
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3.8.1 Building the Application

The main build command in the IDE is the Clean and Build command. The Clean and Build

command deletes previously compiled classes and other build artifacts and then rebuilds the entire

project from scratch.

To build the application:

Choose Run > Clean and Build Main Project (Shift-F11).

Output from the Ant build script appears in the Output window. If the Output window does not

appear, you can open it manually by choosing Window > Output > Cutput.

When you clean and build your project, the following things occur:

Output folders that have been generated by previous build actions are deleted ("cleaned”).

(In most cases, these are thebuild and dist folders.)

build and dist folders are added to your project folder (hereafter referred to as
the PROJECT HOME folder). You can view these folders in the Files window.

All of the sources are compiled into .class files, which are placed into

the PROJECT _HOME/build folder.
A JAR file containing your project is created inside the PROJECT HOME/dist folder.

If you have specified any libraries for the project (in addition to the JDK), a lib folder is

created in the dist folder. The libraries are copied into dist/lib.

The manifest file in the JAR is updated to include entries that designate the main class and

any libraries that are on the project's classpath.

3.8.2 Running the Application Outside of the IDE

i Torun the application outside of the IDE:
1.

On your system, open up a command prompt or terminal window.

2. In the command prompt, change directories to the MyApp/dist directory.

3. At the command line, type the following statement:

java -jar MyApp.jar However we all feel zealous

The application then executes and returns the following output as shown in the image below:

i Result = Hello

-B
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Fig 9: Command Prompt Execution of Java Programs

3.8.3 Distributing the Application to Other Users
Now that you have verified that the application works outside of the IDE, you are ready to distribute | |
the application. |
To distribute the application:

1. On your system, create a zip file that contains the application JAR file (MyApp.jar) and the
accompanying lib folder that contains MyLib.jar.

= = - == ==

2. Send the file to the people who will use the application. Instruct them to unpack the zip file,

ki

making sure that theMyApp.jar file and the lib folder are in the same folder.

3. Instruct the users to follow the steps in the Running the Application Outside of the

IDE section above.

3.9 Other Common Tasks
You have now completed the main part of the tutorial, but there are still some basic tasks that have

not been covered. This section includes a few of those tasks.

3.9.1 Making the Javadoc Available in the IDE

' To view the JavaSE API documentation in the NetBeans IDE, use the Source > Show
Documentation command or choose Window > Other > Javadoc from the main menu to view API
documentation in a separate window.
However, for some third-party libraries, API documentation is not available. In these cases, the

Javadoc resources must be manually associated with the IDE.
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To make the Javadoc API documentation available for the Show Javadoc command:

1. Download the Javadoc API documentation source.
5. Choose Tools > Libraries.

3. In the Libraries list, select the library that your project is using.

4. Click the Javadoc tab.
5. Click the Add ZIP/Folder button and navigate to the zip file or the folder that contains the
Javadoc API documentation on your system. Select the zip file or the folder and click the

Add ZIP/Folder button.

6. Click Close.

3.9.2 Generating Javadoc for a Project

1 You can gencrate compiled Javadoc documentation for your project based on Javadoc comments

that you have added to your classes.

To generate Javadoc documentation for a project:
| I. Select the MyLib project.
2. Choose Run > Generate Javadoc for "MyLib" from the IDE's main menu.

. The generated Javadoc is added to the dist folder of the project. In addition, the IDE opens a web b

browser that displays the Javadoc.

t 3.10 Basic Project Concepts

** This section provides an overview of some background information on the IDE's project system.

13101 Projects

i In the IDE, you always work inside of a project. In addition to source files, an IDE project contains
_E metadata about what belongs on the classpath, how to build and run the project, and so on. The IDE
E stores project information in a project folder which includes an Ant build script and properties file
that control the build and run settings, and aproject.xml file that maps Ant targets to IDE

Commands,

E‘
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3.10.2 Ant

Apache Antis aJ ava-based build tool used to standardize and automate build and run environments
sor development. The IDE's project system is based directly on Ant. All of the project commands,
like Clean and Build Project and Debug, call targets in the project's Ant script. You can therefore

‘ build and run your project outside the IDE exactly as it is built and run inside the IDE.

1t is not necessary to know Ant to work with the IDE. You can set all the basic compilation and
untime options in the project's Project Properties dialog box and the IDE automatically updates
your project's Ant script. If you are familiar with Ant, you can customize a standard project's Ant

seript or write your own Ant script for a project.
Creating a Project
To create a new project:

» Choose File > New Project (Ctrl-Shift-N).

P

When the New Project wizard appears, select the right template for your project and complete the

remaining wizard steps. In the releases later than NetBeans IDE 6.7, the project template icon can

be displayed in gray, which means that this project type has not been activated. Proceed with

A0, il

creating the project and this functionality will be activated in the IDE.

The IDE contains the following standard project templates for Java desktop and web applications:

Java Application. Creates a skeleton Java SE project with a matn class.

+ Java Desktop Application. Creates an application based on the Swing Application
Framework. Skeletons are offered for a basic desktop application and a database application

that makes use of the Beans Binding and Java Persistence API libraries.

+ Java Class Library. Creates a skeleton Java class library without a main class.

+ Java Project with Existing Sources. Creates a Java SE project based on your own Java

S0uUrcces.

*  Web Application. Creates a skeleton web application, including options to add various web ‘

frameworks

*  Web Application with Existing Sources. Creates a web project based on your own web

and Java sources.
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In addition, the IDE also contains templates for EJB modules, enterprise applications, Java ME

applications, and more.

The Java and Web project categories also have free-form project templates. The free-form templates

enable you to use an existing Ant script for a project but require manual configuration.

} When you finish creating a project, it opens in the IDE with its logical structure displayed in the

Projects window and its file structure displayed in the Files window:

« The Projects window is the main entry point to your project sources. It shows a logical view
of important project contents such as Java packages and Web pages. You can right-click any
project node to access a popup menu of commands for building, running, and debugging the
project, as well as opening the Project Properties dialog box. The Projects window can be

opened by choosing Window > Projects (Ctrl-1).

« The Files window shows a directory-based view of your projects, including files and folders
that are not displayed in the Projects window. From the Files window, you can open and edit
your project configuration files, such as the project's build script and propetties file. You can
also view build output like compiled classes, JAR files, WAR files, and generated Javadoc

documentation. The Files window can be opened by choosing Window > Files (Ctrl-2).

SR WHelloweb E-S3 Helloweb
E} {ﬁ web Pages E} eﬂ nbproject

6] META-INF : [:} 171 private
[13 {2 WEB-IN . E} ] ant-deploy.xm!
LB index.jsp - @3- buildmpl.xmi

E} ﬁ@ Source Packages E-} - genfiles.properties
L-fE org.me.hello [i-} @ project.properties
’Eﬂ L;brarles . project.xml

-8 10K 1.6 (Default) L”_‘] src
: &-[Ef Apache Tomcat 7.0.6 (;‘] web
3§ Configuration Files w-F4 build. !

- [§) MANIFEST.MF

context, xmi

Fig 10: Apache Ant Home Screen
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3.10.3 Importing a Project
| This section shows you how to handle the initial importing of projects into the IDE.
" 3.10.3.1 Importing an Eclipse Workspace

> For Eclipse projects, you can use the Import Eclipse Project wizard to help you create NetBeans
projects from projects in an Eclipse workspace and import the project classpaths and other settings.
When you use the Import Eclipse Project wizard, you do not need to use create and configure the

NetBeans project manually. Open the wizard by choosing File > Import Project > Eclipse Project.
3.10.3.2 Setting Up a Java Project Based on Existing Sources

For other Java projects developed outside of NetBeans, you use an "Existing Sources" template in
the New Project wizard to make a NetBeans project. In the wizard, you identify the location of the
sources and specify a location for the NetBeans project metadata. You then use the Project

Properties dialog box to configure the project.
To set up a NetBeans project for an existing Java application: b
1. Choose File > New Project (Ctrl-Shift-N).

2. Choose Java > Java Project with Existing Sources. Click Next.

— TR =l

3. Inthe Name and Location page of the wizard, follow these steps:
o Type a project name.
o (Optional) Change the location of the project folder.

o (Optional) Change the name of the build script used by the IDE. This might be
desirable if there is already a build script called build.xml that is used to build the

Sources.

o (Optional) Select the Use Dedicated Folder for Storing Libraries checkbox and

specify the location for the libraries folder.

o (Optional) Select the Set as Main Project checkbox. When you select this option,
keyboard shortcuts for commands such as Clean and Build Main Project (Shift-F11)
apply to this project.

4. Click Next to advance to the Existing Sources page of the wizard.
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P 5. [n the Source Packages Folder pane, click Add Folder. Then navigate to your sources and

select the source roots, click Open.

when you add a folder containing source code, you must add the folder that contains the highest |
folder in your package tree. For example, for the com mycompany.myapp.ui package, you add the

- } folder that contains the com folder.

6. (Optional) In the Test Package Folders pane, click Add Folder to select the folder containing
the JUnit package folders.

7. Click Next to advance to the Includes & Excludes page of the wizard.

8. (Optional) In the Includes & Excludes page of the wizard, enter file name patterns for any
files that should be included or excluded from the project. By default, ali files in your source

roots are included.

9. Click Finish,

Pt -

3.10.3.3 Setting Up a Web Project Based on Existing Sources

For web projects developed outside of NetBeans, you use an "Existing Sources" template in the

New Project wizard to make a NetBeans project. In the wizard, you identify the location of the

e By i

sources and specify a location for the NetBeans project metadata. You then use the Project

Properties dialog box to configure the project.
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CHAPTER 4

sample Code.
4.1 Recorder.java:

» package org.multichat.client;
jmport org.multichat.CommonSoundClass;

import java.io.ByteArrayOutputStream;

javax.sound.sampled.Dataline;
javax.sound.sanmnpled.TargetDataline;
javax.sound.sampled.AudioFormat;
javax.sound.sampled.AudioSystem;
javax.sound.sampled.AudioInputStream;
javax.sound.sampled.LineUnavailableException;
javax.sound.sampled.AudioFileFormat;

public class Recorder

extends Thread {

private TargetDataline m line;

private AudioFileFormat.Type m targetType;
private AudioInputStream m_audioInputStream;
private booclean m bRecording;

private boolean m bQuitting;

public byte bs[];
public static CommonScundClass cs;

boolean onlyonce = false;

public Recorder (Common3oundClass csPtr) {

this.cs = csPtr;
boolean gotrecordingline = true;

ByteArrayOutputStream outputFile = new ByteArrayOQutputStream{);
AudioFcormat audioFormat = null;

// 8 kHz, 8 bit, mono

audioFormat = new AudioFormat (AudioFormat.Encoding.PCM SIGNED,

ClientShared.sampleRate, ClientShared.sampleSize, 1, 1,
ClientShared.frameRate, false};

// 44.1 kHz, 16 bit, stereo
audioFormat = new AudioFormat( AudioFormat.Encoding.PCM SIGNED,

44100.0f, 16, 1, 2, 44100.0f, false );

audioFormat = new AudioFormat (AudioFormat.Encoding.PCM SIGNED,

44100.0F, 16, 2, 4, 44100.0F, false);

// Get Line (microphone) Information

DataLine.Info info = new Dataline.Info(TargetDataline.class,
dudioFormat) ;
TargetDataLine  targetDatalLine = null;
30
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-3 try {
// Connect to line

targetDataline = (TargetDataline) AudioSystem.getLine (info);
targetDatal.ine.open(audioFormat});

AR |

}

catch (LineUnavailableException e) |{
System.err.println("Error: Unable to get a recording line");
gotrecordingline = false;

} //e.printStackTrace();

//8ystem,exit (1);

if {gotrecordingline) {
AudioFileFormat.Type targetType = AudiocFileFormat.Type.AU;
// Recorder recorder = null;
RecorderInit (targetDataline, targetType):
m_bRecording = true;
m bQuitting = false;
this.start (});

public void RecorderInit(TargetDataline line, AudioFileFormat.Type
targetType) { )
m line = line;
m audioInputS8tream = new AudioInputStream({line);
m targetType = targetlType;

i~

___.
L -y

/**
* Starts the recording.
* To accomplish this, (i) the line is started and (ii} the
* thread is started.
*/
public void start{)
m_bRecording =
m line.start{);
super.start{):

{
true;

}

public void startRecording{} {
m_bRecording = true;

}

public void stopRecording{) { :
m_bRecording = false;
onlyonce = true;

} f

synchronized public void run{) {
while ( 'm bQuitting ) {
byte bs[] = new byte[ClientShared.audioReadBytes};
m line.read(bs, O, ClientShared.audioReadBytes);

if (m_bRecording) {
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cs.writebyte (bs);

} else if (onlyonce) {
cs.writebyte (("NT|") .getBytes ());
onlycnce = false;

}

m line.stop();
’ m line.close();

}

public void onExit () {
m bQuitting = true;
}

4.2 CommonSoundClass.java:

"// $Id: Queue.java,v 1.1 2001/05/04 21:22:05 mito Exp $
package org.multichat;

import java.util.*;

public class CommonSoundClass ({
public Vector vec = new Vector();
boolean lock = true;
private byte b[]:

public CommonSoundClass () |
}

synchronized public Object readbyte(} {

try {

while (vec.isBEmpty{)) |{
wait () ;

}

}

catch {InterruptedException ie) {
System.err.println{"Error: CommonSoundClass readbyte

interrupted”);

}

if (! vec.isEmpty{)) {

1 b = (byte([]} vec.remove(0):
return b;

} else {
byte[] b = new byte[b];
return b;

}

synchronized public void writebyte (Cbject e) {
vec.addElement (e} ;
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lock = false;
notifyAll () ;

4.3 Playback.java:

package org.multichat;
J/ $Id: org.multichat.Playback.java,v 1.5 2001/05/04 21:13:09 mito Exp $
import org.multichat.client.ClientShared;
import javax.sound.sampled.*;
public class Playback implements Runnable {
// Data written to this is played by the soundcard

private SourceDataline sdl;

// Write this many bytes per inner loop execution
static private final int innerLoopWriteSize = 2048;

// new sounds to be played are placed on this queue
private Queue incoming = new Queue();

// lock to wait on when waiting for a sound to play
private Object soundLock = new Object():

e — N i

// assume a standard sampling rate
static final public int sampRate = 8000;

// the latency through the low-level sound system |
// this must be tuned for each system
static private final double sysLatencyTime = 0.6%5;

// the sound latency expressed in samples"

static private final int sysLatency =
{int) {(sysLatencyTime*sampRate) ;

// a standard audio format for playing audio

static public AudioFormat stdFormat =

rnew AudioFormat (AudioFormat.Encoding.PCM SIGNED,
ClientShared.sampleRate, ClientShared.sampleSize, 1, 1,
ClientShared. frameRate, false);

// The construtor opens a playback audio line
// and creates a background thread for streaming data
public Playback{) {

// Open the playback line

sdl = getOutputLine(});

// Create a background thread for streaming audio
Thread t = new Thread{ this, "playbkack" );
t.start ();
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public Playback( byte b[] }/{
sdl = getCutputline():
// Create a background thread for streaming audio |
Thread t = new Thread{ this, "playback" ); |
t.start ()
this.setSound{ b );

// Tell the playback to play the next sound : ;
// set to null to turn sound off
public void setSound{ byte raw[] ) {
synchrenized (soundLock) |
// place the new sound on the queue
incoming.put{ raw ); !

// tell the thread that there's a new sound
soundLock.notifyall {};

}

// Background streaming thread

public void run{) {
// The currently playing sound A
byte currentRaw[] = null; %
// The position within the currently playing sound q
int cursor = 0; i

// open the output line for playing

try {
// open it with our standard audio format
sdl.open{ stdFormat );

// start it playing
sdl.start (),
} catch{ LineUnavailableException lue ) {
throw new RuntimeException( lue.toString{) ):

}

while (true) {
synchronized (soundLock) {
while({ true }{
if (incoming.numWaiting () >0) {

currentRaw = (byte[])incoming.get();
break;
}else{
try | '
soundLock.wait (50); ]
} catch({ InterruptedException ie ) {} I
} i
!

}

cursor = 0;
int bytesLeft = currentRaw.length - cursor;
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do{
if (sdl.available()>0) {
int r = Math.min(sdl.available (),
currentRaw.lengthwcursor);
sdl.write{ currentRaw, curscr, r );
if {r==-1)
throw new RuntimeException{ "Can't write to

1ine!™ J):
cursor+=r;
} else {
try |
soundLock.wait (10);
}catch{ InterruptedException ie } {}
}
} while{currentRaw.length-cursor > 0);
}
}
}
// Utility class -- open an output line with our standard

// audic format
public SourceDataline getOutputLine() {
try {
Dataline.Info info =
new Dataline.Info( SourceDatalLine.class, stdFormat )};

SourceDataLine sdl = (SourceDataline)AudioSystem.getLine (
info );
return sdl;
} catch( LineUnavailableException lue ) {
throw new RuntimeException( "Can't get output line" );
}
}
}
4.4 Playback.java:

package org.multichat;

// $1d: Queue.java,v 1.1 2001/05/04 21:22:05 mito EXp $

import java.util.*;

public class Queue |
// Internal storage for the queue'd objects
private Vector vec = new Vector():
booclean prebuffer = true;
// lLower this rate for guicker delivery of audio
int queueWaitSize = 12;/*16 * 5 + 1*/

synchronized public int numWaiting{) {
// makes the client wait for more packets before starting to play
them
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-1 // this takes care of the buffer :)

// This makes sound clearer but also causes delays in receiving
audio.
if( prebuffer g& vec.size{) < queueWaitSize) {
return 0;
} else |{
prebuffer = false;
return vec.sizel();

] }

}

synchronized public void put{ Object o ) {
// Bdd the element
vec.addElement( © )
// There might be threads waiting for the new object --
// give them a chance to get it
notifyAll ();
1

synchreonized public Object get () {
while (true) {
if ( numWaiting(} > 0 /*vec.size(}>0*/ } {

// remove the bytes if its more then 1.5 seconds delay

while({ vec.size(} > (24 /*16 * 10*/) ) {
vec.removeFElementAt (0} ;

}

// There's an available object!
Object o = vec.elementAt{ 0 };

// Remove it from our internal list, so someocone else
// doesn't get it.

/*int vectorsize = vec.slzel():

if( vectorsize > 1 ){

vectorsize = 1;
}

int j = 0;

int i = 0;

byte[] bigbyte = new byte[vectorsize * (1024*8)]);
for(; 1 < vectorsize * 512; i++}{
if{ 3 == 1024*8 ) {
i3 = 0;
vec. removeElementAt (0);
i
bigbyte[i] = {((byte[]) (vec.elementAt{ 0 }))[]];
J++;
y*/

vec.removeElementAt{ 0 };

//System.out.println("buffer is " + vec.size() );
if( vec.size() == ) {
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- prebuffer = true; // we have reached the last element in
the stack we shuld buffer more data before plaving
}

// Return the object
return o;
//return (Object)bigbyte;
} else {
// There aren't any objects available. Do a wait(),
// and when we wake up, check again to see if there
// are any.
try { wait({):; } catch{ InterruptedException ie } {}

)

4.5 Sock.java:

/*
* To change this template, choose Tools | Templates
* and open the template in the editor.

*/
package chat application;

import java.io.BufferedReader;
import java.io.IOException;
import java.io.lInputStream;
import java.io.InputStreamReader; (!
import java.io.OutputStream;
impert java.io.OutputStreamWriter;
import java.ic.PrintWriter;
}import java.net.ConnectException;
import java.net.ServerSocket;
import java.net.Socket;
import java.net.SocketException;

—_— e

public class sock {
String name;
long time_entry;
long timespend;
String 1ip;
Socket s,temp;
client entry chaman;
BufferedReader br,br2;
String str;
PrintWriter pr;

sock ()
{
chaman =new client entry{);
java.awt.EventQueue.invokeLater(new Runnable () {
public void runf() {
chaman.setVisible (true) ;

}
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Socket getsock()}
{

return s;

}

String getname () i
{
|

return name;

}
void setsock() ‘
{
try
{
name=chaman.strl; /Y bhokaal error
time_entry=System.currentTimeMillis()/1000;
ip=chaman.getstrd():
s=new Socket (ip,4437);
}
catch {SocketException 11)
{
System.out.println("check point 1");
}
catch{IOException e)
{

System.out.println("io exception ....");

}

public static void main(String args|[])
{
sock cl=new sock(};
try
{
Thread.sleep(13000);
} .
catch (Exception e)
{}
cl.setsock(): N
clinfol ¢ =new Clinfol (cl.getsock{)); |
Thread t=new Thread(c};
Clinfo2 c2 =new Clinfo? (cl.getsock{),cl.getname(});
Thread tZ2=new Thread(c2);
f t.start{);
t2.start ()

} 1
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4.6 Pop_up.java:

public class pop up extends javax.swing.JFrame {

/** Creates new form pop_up */
public pop up() { _

initComponents () ; |
} ' !

/** This method is called from within the constructor to
* initialize the form.
* WARNING: Do NOT modify this code. The content of this method is
* always regenerated by the Form Editor.
*/
@SuppressWarnings ("unchecked")
// <editor-fold defaultstate="collapsed" desc="Generated Code">//GEN-
BEGIN: initComponents
private void initCemponents{) ({

jLabell = new javax.swing.JLabel(};
jButtonl = new javax.swing.JButton({);
setDefaultCloseOperation(javax.swing.WindowConstants.EXITWON#CLOSE);

jLabell.setFont (new java.awt.Font ("Tahoma", 1, 12)); // NOI18N
jLabell.setText ("Name & Email id can't be left blank .");

jButtonl.setText ("OK");
jButtonl.addActionListener (new java.awt.event.ActionListener{) {
public void actionPerformed(java.awt.event.ActionEvent evt) {
jButtonlActionPerformed(evt) ;
}
b

javax.swing.GroupLayout layout = new
javax.swing.GroupLayout (getContentPane ()}

getContentPane () .setLayout (layout);

layout.setHorizontalGroup |

layout.createParallelGroup(javax.swing.GroupLayout.Alignment.LEADING)
.addGroup (layout.createSequentialGroup ()

‘addGroup(layout.createParallelGroup(javax.swing.GroupLayout.Alignment.LE
ADING)
.addGroup (layout.createSequentialGroup ()
.addGap (35, 35, 35) :
.addComponent (jLabell,
javax.swing.GroupLayout.PREFERRED SIZE, 233,
javax.swing.GroupLayoult .PREFERRED_SIZE))
.addGroup (layout.createSequentialGroup ()
.addGap {119, 1192, 119)
.addComponent (jButtonl)))
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.addContainerGap (20, Short.MAX VALUE))
)i
layout.setVerticalGroup |

layout.createParallelGroup(javax.swing.GroupLayout.Alignment.LEADING)
.addGroup (layout.createSequentialGroup{)
.addComponent (jLabell,
javax.swing.GroupLayout.PREFERRED_SIZE, 35,
javax.swing.GroupLayout.PREFERRED#SIZE)

.addPreferredGap (javax.swing.LayoutStyle.ComponentPlacement.RELATED)
.addComponent {(jButtonl)
.addContainerGap{javax.swing.Grouplayout.DEFAULT SIZE,

short. MAX_VALUE) )

) 7

pack(};
}// </editor-fold>//GEN-END:initComponents

private void jButtonlActionPerformed(java.awt.event.ActionEvent evt)
{//GEN-FIRST:event jButtonlActionPerformed
this.setVisible(false);

}//GEN-LAST:event jButtonlActionPerformed

/-k-k
* @param args the command line arguments

*/

// Variables declaration - do not modify//GEN-BEGIN:variables
private javax.swing.JButton jButtonl;

private javax.swing.JLabel jLabell;

// Bnd of variables declaration//GEN-END:variables

4.7 Client_entry.java:

package chat application;

public class client_entry extends javax.swing.JFrame {
pbrivate pop_up p:

String strl,str2,str3,strd;

public client entry{)
{ initComponents () ;
Stri;g getstrl()
%eturn strl;

String getstrd{)
{
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return strid;

}

@suppressWarnings {"unchecked")

// <editor-fold defaultstate="collapsed"” desc="Generated Code">//GEN-
BEGIN:initComponents

private void initComponents{) { 1

! jLabell = new javax.swing.JLabel (); |
jSeparatorl = new javax.swing.JSeparator(}; |
jLabel2 = new javax.swing.JLabel ();
jtfl = new javax.swing.JTextField(): : b
jLabel3 = new javax.swing.JLabel(); i
jtf2 = new javax.swing.JTextField(}; |
jLabeld new javax.swing.JLabel (}; i
jLabel5 = new javax.swing.JLabel (}; ﬂ
jLabelé new javax.swing.JLabel(); |
jtf3 = new javax.swing.JTextField();
jLabel? = new javax.swing.JLabel()};
jButtonl = new javax.swing.JButton();
jLabel8 = new javax.swing.JLabel();
jLabel9 = new javax.swing.JLabel();
jtf4 = new javax.swing.JTextField(};
jLabell0 = new javax.swing.JLabel ()

1l

Il

. i
r 1

setDefaultCloseOperation (javax.swing.WindowConstants.EXIT_ON_CLOSE);
setTitle ("cLiEnT sUpPoRt WiNdOw");
setCursor (new java.awt.Cursor(java.awt.Cursor.DEFAULT_CURSOR));
setResizable (false)

jLabell.setFont(new java.awt.Font ("Tahoma", 3, 36));
jLabell.setText ("EnTeR DeTaIlS");

i jLabel2.setFont (new java.awt.Font ("Tahoma", 1, 14));
jLabel2.setText ("Enter NAME : "y ;
jtfl.addActionListener (new java.awt.event.ActionListener () {

public void actionPerformed(java.awt.event.ActionEvent evt) {
jtflActionPerformed{evt);
}

I

jLabel3.setFont (new java.awt.Font ("Tahoma", 1, 14)); :
jLabel3.setText ("Enter CUSTOM TAG : "); |
jLabeld.setText ("*"}; j
jLabel5.setText ("* Fields marked with ' * ' are compulsory to
i enter ."};

jLabel5.setBorder (new javax.swing.border.MatteBorder (null))

jLabel6.setFont (new java.awt.Font ("Tahoma", 1, 14));
jLabel6.setText ("Email Address ")y }

jLabel7.setText ("*");
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jButtonl.setBackground (new java.awt.Color (255, 255, 255));

:guttonl.setText ("<html>\nS<br><br>\nU<br><br>\nB<br><br>\nM<br><br>\nI<b
r><br>\nT<br><br>\n</html>") ;

jButtonl.setBorder(javax.swing.BorderFactory.createEtchedBorder(javax.swi
ng.border.EtchedBorder.RAISED, java.awt.Color.orange,
java.awt.Color.yellow));
jButtonl.addActionListener (new java.awt.event.ActionListener () {
public void actionPerformed(java.awt.event.ActionEvent evt) ({
jButtonlActionPerformed (evt) ;
1
)i

jLabel9.setFont (new java.awt.Font ("Tahoma", 1, 16));
jLabel9.setText ("SeRvExr IP :");

jLabellO.setText ("*");

javax.swing.GroupLayout layout = new
javax.swing.GroupLayout (getContentPane()) ;

getContentPane () .setLayout (layout) ;

layout.setHorizontalGroup (

layout.createParallelGroup (javax.swing.GroupLayout.Alignment.LEADING)
.addComponent (jSeparatorl,
javax.swing.GroupLayout.DEFAULT SIZE, 456, Short.MAX VALUE)
.addGroup (layout.createSequentialGroup ()

.addGroup (layout.createParallelGroup (javax.swing.GroupLayout.Alignment.LE
ADING)
.addGroup (layout.createSequentialGroup ()
.addContainerGap ()

| .addGroup (layout.createParallelGroup (javax.swing.GroupLayout.Alignment.LE

ADING, false)
.addGroup (layout.createSequentialGroup ()

.addGroup (layout.createParallelGroup (javax.swing.GroupLayout.Alignment.TR
ATLING, false)

.addGroup {javax.swing.GroupLayout.Alignment.LEADING,

layout.createSequentialGroup ()
.addComponent (jLabel3,

javax.swing.GroupLayout.PREFERRED SIZE, 166,
javax.swing.GroupLayout.PREFERRED SIZE)

.addPreferredGap (javax.swing.LayoutStyle.ComponentPlacement.RELATED)
.addComponent (jtf2))

.addGroup (javax.swing.GroupLayout.Alignment .LEADING,

layout.createSequentialGroup ()
.addComponent (jLabel2)

.addGap (18, 18, 18)

.addComponent (jtfl,
javax.swing.GroupLayout.PREFERRED SIZE, 228,
javax.swing.GroupLayout.PREFERRED)SIZE)))
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.addPreferredGap(javax.swing.LayoutStyle.ComponentPlacement.UNRELATED)
.addComponent (jLabeld,
javax.swing.GroupLayout.DEFAULT_SIZE,
javax.swing.GroupLayout.DEFAULT_SIZE, Short .MAX VALUE})
.addGroup (layout.createSequentialGroup ()
.addComponent (jLabelé,
\javax.swing.GroupLayout.PREFERRED_SIZE, 119,
javax.swing.GroupLayout.PREFERRED_SIZE)

.addPreferredGap (javax.swing.LayoutStyle.ComponentPlacement.RELATED)
.addComponent (jt£f3,

javax.swing.GroupLayout.PREFERRED_SIZE, 225;

javax.swing.GroupLayout.PREFERRED_SIZE)

.addPreferredGap (javax.swing.LayoutStyle.ComponentPlacement.UNRELATED)
.addComponent (jLabel7))

.addComponent (jLabelb5,
javax.swing.GroupLayout.PREFERRED SIZE, 298,
javax.swing.GroupLayout.PREFERRED_SIZE))}

.addGroup (layout.createSequentialGroup ()

.addGroup (layout.createParallelGroup(javax.swing.GroupLayout.Alignment.TR
AILING, false)

.addGroup (javax.swing.GroupLayout.Alignment . LEADING,

layout.createSequentialGroup ()
.addContainerGap ()

.addComponent (jLabel9,
javax.swing.GroupLayout.PREFERRED SIZE, 122,
javax.swing.GroupLayout.PREFERRED SIZE)

.addPreferredGap (javax.swing.LayoutStyle.ComponentPlacement.RELATED)
.addComponent (jtf4))

.addGroup (javax.swing.GroupLayout.Alignment .LEADING,

layout.createSequentialGroup ()
.addGap (51, 51, 51)

.addComponent (jLabel8,
javax.swing.GroupLayout.PREFERRED SIZE, 271,
javax.swing.GroupLayout.PREFERRED SIZE)})

.addPreferredGap (javax.swing.LayoutStyle.ComponentPlacement.UNRELATED)
.addComponent (jLabell0)))
.addGap (38, 38, 38)
.addComponent (jButtonl,
javax.swing.GroupLayout.DEFAULT SIZE, 44, Short.MAX VALUE))
.addGroup (javax.swing.GroupLayout.Alignment.TRATILING,
layout.createSequentialGroup ()
.addContainerGap (90, Short.MAX VALUE)
.addComponent (jLabell,
javax.swing.GroupLayout.PREFERRED SIZE, 290,
javax.swing.GroupLayout.PREFERRED SIZE)
.addGap (76, 76, 16))
)
layout.setVerticalGroup (
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layout.createParallelGroup(javax.swing.GroupLayout.Alignment.LEADING)
.addGroup (layout.createSeqguentialGroup ()
.addComponent (jLabell,
javax.swing.GroupLayout.PREFERRED_SIZE, 68,
javax.swing.GroupLayout.PREFERRED_SIZE)

_addPreferredGap (javax.swing.LayoutStyle.ComponentPlacement.RELATED)
.addComponent (jSeparatorl,
javax.swing.GroupLayout.PREFERRED_SIZE, 10,
javax.swing.GroupLayout.PREFERRED_SIZE)
.addGap (18, 18, 18)

.addGroup (layout.createParallelGroup (javax.swing.Grouplayout.Alignment . TR

AILING, false)
.addGroup (layout.createSequentialGroup ()

.addGroup (layout.createParallelGroup (javax.swing.GroupLayout.Alignment . BA
SELINE)
.addComponent (jLabel?2)

: .addComponent (jtf1,
javax.swing.GroupLayout.PREFERRED SIZE,
javax.swing.GroupLayout.DEFAULT SIZE,
javax.swing.GroupLayout.PREFERRED_SIZE)

.addComponent (jLabeld))
.addGap (29, 29, 29)

.addGroup (layout.createParallelGroup(javax.swing.GroupLayout.Alignment.LE
ADING, false)
.addComponent (jLabel3)
.addComponent (jtf2,
javax.swing.GroupLayout .DEFAULT SIZE, 61, Short.MAX VALUE))
.addGap {17, 17, 17)

.addGroup {layout.createParallelGroup(javax.swing.GroupLayout.Alignment.BA
SELINE)
.addComponent (jLabel6)
.addComponent (jt£3,
javax.swing.Grouplayout.PREFERRED SIZE,
javax.swing.GroupLayout.DEFAULT SIZE,
javax.swing.GroupLayout.PREFERRED SIZE)
.addCcmponent (jLabel?)})
.addGap (27, 27, 27)
.addComponent (jLabel8)
.addGap (4, 4, 4}

.addGroup (Llayout.createParallelGroup (javax.swing.GroupLayout.Alignment. BA

SELINE)
.addComponent (jLabel9)
.addComponent (jt£4,
javax.swing.GrouplLayout.PREFERRED SIZE,
javax.swing.GroupLayout.DEFAULT SIZE,
javax.swing.GroupLayout.PREFERRED SIZE)
.addComponent (jLabell0))

.addPreferredGap (javax.swing.LayoutStyle.ComponentPlacement.RELATED, 41,
Short.MAX VALUE) :
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.addComponent (jLabel5))
.addComponent (jButtonl,
javax.swing.GroupLayout.Alignment.LEADING,
javax.swing.GroupLayout.PREFERRED_ SIZE, 255,
javax.swing.GroupLayout.PREFERRED SIZE))
.addContainerGap())

) ;

pack () ;
}// </editor-fold>//GEN-END:initComponents

private void jtflActionPerformed(java.awt.event.ActionEvent evt)
{//GEN-FIRST:event jtflActionPerformed
// TODO add your handling code here:
} //GEN-LAST:event jtflActionPerformed

private void jButtonlActionPerformed(java.awt.event.ActionEvent evt)
{//GEN-FIRST:event_ jButtonlActionPerformed

r

strl=jtfl.getText (
str2=jtf2.getText (
str3=jtf3.getText (
(
)

)
)i
) .
)

r

strd=jtf4d.getText

r

1f (strl.equals (™" | str3.equals("") || strd.equals(""))
{
p=new pop up();
java.awt.EventQueue.invokeLater (new Runnable () {
public void run{() {

p.setVisible (true);

else

{
this.setVisible (false);

java.awt.EventQueue.invokeLater (new Runnable () {
public void run() {
new client (strl+" : "+str2,str3).setVisible(true);

}
by

}
} //GEN-LAST:event jButtonlActionPerformed

/**

* @param args the command line arguments

%)

// Variables declaration - do not modify//GEN-BEGIN:variables
private javax.swing.JButton jButtonl;

private javax.swing.JLabel jLabell;

private javax.swing.JLabel jLabellQ;

private javax.swing.JLabel JjLabelZ2;

private javax.swing.JLabel jLabel3;

private javax.swing.JLabel jLabeld;
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private javax.swing.
private javax.swing.
private javax.swing.
private javax.swing.
private javax.swing.
private javax.swing.
private Jjavax.swing.
private javax.swing.
’ private javax.swing.

private javax.swing.
// End of variables

4.8 Cl_infol.java:

import java.net.Socket;

import exception.*;

{
Socket 33
BufferedReader br2;
String str;
PrintWriter pr;
static boolean mode;
public Clinfol()
{

}

private String line;

Clinfol (Socket s)
{

this.s=s;

}

ROoverride

JLabel
JLabel
JLabel
JLabel
JLabel

jLabel5;
jLabel6;
jLabel7;
JjlLabel8;
jLabel9;

JSeparator JjSeparatorl;
JTextField jtfl;

JText¥Field JjtfZ;

JTextField jt£3;

JTextField jtfd;
declaration//GEN-END:variables

package chat application;

import java.io.BufferedReader;
import java.io.DatalnputStream;
import java.io.IOException;
import java.io.InputStream;
import java.io.InputStreamReader;
import java.io.OutputStream;
import java.io.OutputStreamWriter;
import java.io.PrintWriter;
import java.net.ConnectException;

import java.util.logging.Level;
import java.util.legging.Logger;
public class Clinfol extends Thread

import java.net.SocketException;

46




public void runi()
{

try
{

br2=new BufferedReader (new InputStreamReader (s.getInput3tream{})]);

while (true)

{
line = br2.readLine{};
if(!line.equals{""))
System.out.println("server : "+line);

}

}

catch (ConnectException e)

{

System.err.println{"Unable to connect !!! Raising AUTO SERVER
")

Serinfo instance=new Serinfo();

try |
mode = instance.getMode ()
} catch (IOExcepticn ex) {

Logger.getLogger (Clinfol.class.getName()) .log(Level .SEVERE, null, ex);
}

instance.startserver (null);

Thread ts=new Thread(instance);
ts.start ()

}
catch (IOException e)

{
this.interrupt{):
System.err.println("IOException !!! Raising AUTO SERVER

S

Serinfo instance=new Serinfo();
try {
mode = instance.getMode () ; // change of modee errcor

-----

} catch (IOException ex) {

Logger.getlLogger{Clinfol.class.getName{)).log(Level.SEVERE, null, ex});
}

instance.startscrver (null});
Thread ts=new Thread{instance);
ts.start ()

o

}
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4.9 Client.java: ;

package chat application;
Y import java.awt.Graphics;
public class client extends javax.swing.JFrame {

/** Creates new form client */
public c¢lient{)
{

initComponents ()

}

client {String strl, String str3)

{

this ()

jid.setText {strl);

tag.setText {str3);

}

@SuppressWarnings ("unchecked")

// <editor-fold defaultstate="collapsed" desc="Generated Code">//GEN-
BEGIN:initComponents

private void initComponents{) {

jLayeredPanel = new javax.swing.JLayeredPane({);
jPanell = new javax.swing.JPanel();

jid = new javax.swing.JLabel():

tag = new javax.swing.JLabel();

jLabel8 new javax.swing.JLabel();

jLabel9 = new javax.swing.JLabel (); }
jSeparatorl = new javax.swing.JSeparator():;
jScrollPanel = new javax.swing.JScrollPane(); '
list = new javax.swing.JList (}; |
jbl = new javax.swing.JButton();

jTabbedPanel = new javax.swing.JTabbedPane () ;
jInternalFramel new javax.swing.JInternalFrame () ;
jInternalFrame2 new javax.swing.JInternalFrame (};
jTextFieldl = new javax.swing.JTextField{);
jButton2 = new javax.swing.JButton();

I

setDefaultCloseOperation (javax.swing.WindowConstants.EXIT ON_CLOSE); o

jid.setBackground{new java.awt.Color (255, 153, 0)); i“
| jid.setForeground{new java.awt.Color (102, 0, 0)}; |
4id.setText ("Id - custom ."); @

tag.setForeground (new java.awt.Color (102, 0, 0}); ‘
tag.setText ("EMAIL ID"); !

jLabel8.setText ("Inbox"};

jLabel9.setText ("Settings");
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list.setModel (new javax.swing.AbstractListModel () {
String[] strings = { "Item 1", "Item 2", "Item 3", "Item 4",
"Ttem 5" };
public int getSize() { return strings.length; }
public Object getElementAt (int i) { return strings([i]; }
P)i
list.setCursor (new java.awt.Cursor (java.awt.Cursor.HAND CURSOR)) ;
list.addMouselListener (new java.awt.event.MouseAdapter () ({
7 public void mouseClicked(java.awt.event.MouseEvent evt)
listMouseClicked (evt);

t
})yi
jScrollPanel.setViewportView(list);

jbl.setBackground (new java.awt.Color (255, 255, 255));
jbl.setFont (new java.awt.Font("Tahoma", 3, 12)); // NOI18N
jbl.setForeground(new java.awt.Color (102, 0, 0));
jbl.setText ("<html> <br>\nR <br>\nE <br>\nF <br>\nR <br>\nE
<br>\nS <br>\nH <br>\n<html>");
jbl.setToolTipText ("refreshes your friend list");
jbl.addActionListener (new java.awt.event.ActionListener () {
public void actionPerformed(java.awt.event.ActionEvent evt) {
jblActionPerformed({evt) ;
}
}):

jInternalFramel.setTitle ("Block Friend"); A

javax.swing.GroupLayout JjInternalFramelLayout = new |
javax.swing.GroupLayout (jInternalFramel.getContentPane ()) ;

jInternalFramel.getContentPane () .setLayout (jInternalFramellLayout) ;
jInternalFramelLayout.setHorizontalGroup (

jInternalFramelLayout.createParallelGroup (javax.swing.GroupLayout.Alignme
nt.LEADING)
.addGap (0, 257, Short.MAX VALUE)
)i
jInternalFramelLayout.setVerticalGroup (

jInternalFramelLayout.createParallelGroup (javax.swing.GroupLayout.Alignme
nt.LEADING)
.addGap (0, 87, Short.MAX VALUE)

) ; !

‘ jTabbedPanel.addTab ("Sequrity", jInternalFramel);
jInternalFrame2.setTitle ("Send Friend Request"); ‘

jTextFieldl.setText ("enter id");
jTextFieldl.addActionListener (new java.awt.event.ActionListener () ;

public void actionPerformed(java.awt.event.ActionEvent evt) ({
jTextFieldlActionPerformed (evt) ;

}
1)
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jButton2.setText ("Send Invite For Approval");

javax.swing.GroupLayout jInternalFrameZLayout = new
javax.swing.GroupLay0ut(jInternalFrame2.getContentPane());

jInternalFrameZ.getContentPane().setLayout(jInternalFrameZLayout);
jInternalFrame2Layout.setHorizontalGroup ( !

jInternalFrame2Layout.createParallelGroup(javax.swing.GroupLayout.Alignme
nt . LEADING)
.addGroup (jInternalFrame2Layout.createSequentialGroup ()

.addGroup (jInternalFrame2Layout.createParallelGroup (javax.swing.GroupLayo
ut.Alignment.LEADING)

.addGroup (jInternalFrame2Layout.createSequentialGroup ()
.addGap (46, 46, 46)
.addComponent (jTextFieldl,

javax.swing.GroupLayout.PREFERRED_SIZE, 110,

javax.swing.GroupLayout.PREFERRED_SIZE))

.addGroup (jInternalFrame2Layout.createSequentialGroup ()
.addContainerGap ()
.addComponent (jButton?2,
javax.swing.GroupLayout.DEFAULT SIZE, 237, Short.MAX_VALUE)))
.addContainerGap())
)

jInternal Frame2Layout.setVerticalGroup (

jInternalFrameZLayout.createParallelGroup(javax.swing.GroupLayout.Alignme
nt.LEADING)
.addGroup (jInternal Frame2Layout.createSequentialGroup ()

.addGap (26, 26, 26)

.addComponent (jTextFieldl,
javax.swing.GroupLayout.PREFERRED SIZE,
javax.swing.GroupLayout.DEFAULT SIZE,
javax.swing.GroupLayout.PREFERRED SIZE)

.addPreferredGap (javax.swing.LayoutStyle.ComponentPlacement.RELATED, Ty
Short.MAX VALUE)

.addComponent (jButton?2,
javax.swing.GroupLayout.PREFERRED SIZE, 34,
javax.swing.Grouplayout.PREFERRED SIZE))

)

jTabbedPanel.addTab ("Invite", jInternalFrame2); I

javax.swing.GroupLayout jPanellLayoul = new
javax.swing.GroupLayout (jPanell);

jPanell.setLayout (jPanellLayout) ;

jPanellLayout.setHorizontalGroup (

jPanellLayout.createParallelGroup(javax.swing.GroupLayout.Alignment.LEADI

NG)
.addGroup (javax.swing.GroupLayout.Alignment.TRAILING,

| jPanellLayout.createSequentialGroup ()

|
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pent . TRATLING)
.addGroup(jPanellLayout.createSequentialGroup()
_addContainerGap {198, Short .MAX VALUE}
. addComponent {jLabel8d)
.addGap (27, 27, 27)
.addComponent(jLabel9))

jPanellLayout.createSequentialGroup()
.addGap {25, 25, 25}

ment.LEADING)
.addComponent (tag)
.addComponent (jid))

.addPreferredGap(javax.swing.LayoutStyle.ComponentPlacement.RELATED,
Short.MAX_VALUE))) '
.addcap (27, 27, 27))
.addComponent(jSeparatorl,
'javax.swing.GroupLayout.DEFAULT_SIZE, 319, Short.MAX VALUE)
.addGroup(javax.swing.GroupLayout.Alignment.TRAILING,
jPanellLayout.createSequentialGroup()
.addContainerGap ()
.addComponent(chrollPanel,
javax.swing.GroupLayout.PREFERRED_SIZE, 153,
javax.swing.GroupLayout.PREFERRED_SIZE)

.addPreferredGap(javax.swing.LayoutStyle.ComponentPlacement.RELATED,
Short.MAX_VALUE)

.addComponent (jbl,
javax.swing.GroupLayout.PREFERRED_SIZE,
javax.swing.GroupLayout.DEFAULT_SIZE,
javax.swing.GroupLayout.PREFERREDFSIZE))

.addGroup(jPanellLayout.createSequentialGroup()

_addContainerGap ()

.addComponent(jTabbedPanel,
javax.swing.GroupLayout.DEFAULT_SIZE, 272, Short.MAX VALUE)

_addGap (37, 37, 37)}

i );
! jPanellLayout.setVerticalGroup(

. NG}
.addGroup(jPanellLayout.createSequentialGroup{)

,addGroup(jPanellLayout.createParallelGroup(javax.swing.GroupLayout.Align

.addGroup(javax.swing.GroupLayout.Alignment.LEADING,

,addGroup(jPanellLayout.createParallelGroup(javax.swing.GroupLayout;Align

206,

115,

jPanellLayout.createParallelGroup(javax.swing.GroupLayout.Alignment.LEADI

.addGroup(jPanellLayout.createParallelGroup(javax.swing.GroupLayout.Align

ment . BASELINE)
.addComponent(jLabelS)
1 .addComponent(jLabel9))
.addGap (15, 15, 15)
_addComponent (jid)

.addPreferredGap(javax.swing.LayoutStyle.ComponentPlacement.RELATED)
. addComponent {tag)
_addGap (23, 23, 23)
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. .addComponent (jseparatorl,
javax.swing.GroupLayout.PREFERRED SIZE, 10,
javax.swing.GroupLayout.PREFERRED SIZE)

.addPreferredGap (javax.swing.LayoutStyle.ComponentPlacement.RELATED)

.addGroup(jPanellLayout.createParallelGroup(javax.swing.GroupLayout.Align
ment . LEADING)
; .addComponent (jbl,
javax.swing.GrouplLayout.PREFERRED SIZE, 134,
javax.swing.GroupLayout.PREFERRED:SIZE)
.addComponent (jScrollPanel,
javax.swing.GroupLayout.PREFERRED SIZE, 175,
javax.swing.GroupLayout.PREFERRED SIZE))
.addGap (17, 17, 17}
.addComponent {jTabbedPanel,
javax.swing.GroupLayout.PREFERRED SIZE, 150,
javax.swing.GroupLayout.PREFERRED_SIZE) )
) ;

javax.swing.GroupLayout layout = new
javax.swing.GroupLayout(getContentPane());

getContentPane () .setLayout (layout) ;

layout.setHorizontalGroup |

layout.createParallelGroup(javax.swing.GroupLayout.Alignment.LEADING)
.addComponent (jPanell, javax.swing.GroupLayout.DEFAULT_ SIZE,
javax.swing.GroupLayout.DEFAULT_SIZE, Short.MAX VALUE)
)
layout.setVerticalGroup (

layout.createParallelGroup(javax.swing.GroupLayout.Alignment.LEADING)
.addGroup (layout.createSequentialGroup (}
j .addComponent. (jPanell,
javax.swing.GroupLayout.PREFERRED SIZE,
javax.swing.GroupLayout .DEFAULT SIZE,
javax.swing.GroupLayout.PREFERRED SIZE)
.addContainerGap (43, Short.MAX VALUE))

)

packl():
}// </editor-fold>//GEN-END:initComponents

private void iblActionPerformed(java.awt.event.ActionEvent evt)}
{//GEN-FIRST:event_ jblActionPerformed

}//GEN-LAST:event jblActionPerformed

private void jTextFieldlActionPerformed(java.awt.event.ActionEvent
evt) {//GEN-FIRST:event jTextFieldlActionPerformed
| // TODO add your handling code here:
}//GEN-LAST:event jTextFieldlActionPerformed

private void listMouseClicked (java.awt.event.MouseEvent evt) {//GEN-
FIRST:event listMouseClicked

}//GEN-LAST:event listMouseClicked
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private
private
private
private
| private
private
private
private
| private
5 private
private
private
private
private
private

import java.
import Jjava.
import java.
import java.
import java.
, import java.

import java.

import java.
" import java.
i import java.

{

4.10 Request.

javax,

javax
Jjavax

javax.
javax.
javax.
javax.
javax.
javax.
javax.
javax.
javax.
javax.
javax.
javax.
// End of variables

java:

// Variables declaration - do not modify//GEN-BEGIN
swing.
. 8SWing.
.swing.
swing.
swing.
swing.
swing.
swing.
swing.
swing.
swing.
swing.
swing.
swing.
swing.

JButton jButtonZ;
JInternalFrame jInternalFramel;
JInternalFrame jInternalFrame2;
JLabel iLabel8;

JLabel jLabel9;

JLayeredPane jLayeredPanel;
JPanel jPanell;

JScrollPane jScrollPanel;
JSeparator JjSeparatorl;
JTabbedPane jTabbedPanel;
JTextField jTextFieldl;

JButton jbl;

JLabel jid;

JList list;

JLabel tag:;
declaration//GEN-END:variables

io.BufferedReader;
io.DatalnputStream;
io.I0Exception;
io.InputStreamReader;
io.OutputStreamWriter;
io.PrintWriter;
net.ConnectException;
net.Socket;
net.SocketException;
util.ArraylList:;

public final class Request extends Thread

static ArrayList handlers = new ArrayList (20}

private Socket socket;

private BufferedReader in;
private PrintWriter out;
private String str;

public ArrayList gethandler()

{

return handlers;

}

public Request (Socket socket) throws IOException {
this.socket = socket;
out=new PrintWriter (new
OutputStreamWriter(this.socket.getOutputStream()));
in = new BufferedReader (
‘new InputStreamReader(this.socket.getInputStream()));
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t
BOverride
public void run{) {
String line;
synchronized(handlers) {
handlers.add (this);

)
try |

while (true)
{

i line =in.readLine();
if (Serinfo.mode==true)

| for{int i=0;i<handlers.size();it+)
{
synchronized (handlers) {
Request h =
(Request}handlers.get(i);
h.out.printin(line + "\Nr"};
h.out.flush();
}

System.out.println(line);

! |

} I
catch (NullPointerException e}

{

System.out.printin("client disconnected ...."}:;
} n
catch{SocketException t)
{ .
System.out.println("client disconnected ...."}: .

t
catch (IOException e)

{
e.printStackTrace ()

finally { [
try | i
in.close () i

sccket.close(}; \
c;tch{NullPointerException e)
éystem.out.println("client disconnected ...."): Ii
} catch (IOException e)
{

e.printstackTrace();
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finally {
synchronized (handlers)

{

handlers.remove (this);

}

4.11 Servergui.java: \'

public class servergui extends javax.swing.JFrame { e

public serverguil() { !
initComponents () ; f
}
@SuppressWarnings("unchecked")
// <editor-fold defaultstate="collapsed" desc="Generated Code">//GEN-
BEGIN:initComponents
private void initComponents () {

jLabell = new javax.swing.JLabel {);
jSeparatorl = new javax.swing.JSeparator();

jTabbedPanel = new javax.swing.JTabbedPane(); j
jInternalFramel = new javax.swing.JInternalFrame{); I
jInternalframeZ = new javax.swing.JInternalFrame();
jInternalFrame3 new javax.swing.JInternalFrame();
jInternalFramed new javax.swing.JInternalFrame();
jLakel2 = new javax.swing.JLabel();

jscrollPanel = new javax.swing.JScrollPane();
jListl = new javax.swing.JList () ; |
j5crollPane2 = new javax.swing.JScrollPane();
jList2 = new javax.swing.JList ()7

jScrollPane3 = new javax.swing.JScrollPane();
jList3 = new javax.swing.JList();

jButtonl = new javax.swing.JButton();

jButton2 = new javax.swing.JButton();
jInternalFrameS = new javax.swing.JInternalFrame():
jInternalFrameb = new javax.swing.JInternalFrame(};

il

Ik

\

setDefaultCloseOperation(javax.swing.WindowConstants.EXIT_ON_CLOSE};

jLabell.setFont(new java.awt.Font("Tahoma", 1, 36))-
jLabell.setText(" SeRvEr CoNtRoLs")

jInternalFramel.setVisible(true);

javax.swing.GroupLayout jInternalFramelLayout = new
javax.swing.GroupLayout(jInternalFramel.getContentPane());

jInternalFramel.getContentPane().setLayout{jInternalFramelLayout);
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jInternalFramelLayout.setHorizontalGroup{

jInternalFramelLayout.createParallelGroup(javax.swing.GroupLayout.Alignme
nt.LEADING)
,addGap (0, 504, Short .MAX VALUE)
b
jInternalFramelLayout.setVerticalGroup(

jInternalFramelLayout.createParallelGroup(javax.swing.GroupLayout.Alignme
nt.LEADING)
.addGap (0, 238, Short.MAX VALUE)
)i

jTabbedPanel.addTab(" Main ", jInternalFramel);

javax.swing.GroupLayout jInternalFrameZLayout = new
javax.swing,GroupLayout(jInternalFrameZ.getContentPane());

jInternalFrameZ.getContentPane().setLayout(jInternalFrameZLayout);
jInternalFrameZLayout.setHorizontalGroup(

jInternalFrame2Layout.createParallelGroup(javax.swing.GroupLayout.Alignme
nt . LEADING)
.addGap (0, 504, Short.MAXﬁVALUE)
)i
jInternalFrameZLayout.setVerticalGroup(

jInternalFrame2Layout.createParallelGroup(javax.swing.GroupLayout.Alignme

nt.LEADING)
.addGap (0, 238, Short.MAX_VALUE)

)i
jTabbedPanel.addTab(" Cconfigure ", jInternalFrameZ) ;

javax.swing.GroupLayout jInternalFrame3Layout = new
javax.swing.GroupLayout(jInternalFrame3.getContentPane());

jInternalFrame3.getContentPane().setLayout(jInternalFrameBLayout);
jInternalFrame3Layout.setHorizontalGroup{

jInternalFrame3Layout.createParallelGroup(javax.swing.GroupLayout.Alignme

nt.LEADING)
.addGap (0, 504, Short.MAX VALUE)

}i
jInternalFrameBLayout.setVerticalGroup(

jInternalFrame3Layout.createParallelGroup(javax.swing.GroupLayout.Alignme

nt . LEADING)
.addGap (0, 238, Short .MAX_VALUE)

)i
jTabbedPanel.addTab(" gtatistics ", jInternalFrame3);

jLabelZ.setText("Client Name
| Time Conected | Actions”);

jListl.setModel (new javax.swing.AbstractListModel() {
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Stringl] strings = { "Client 1", wclient 2V,
nclient 4", "Client 5" };

public int getSize(} { return strings.length; }

public Object getElementAt (int i) { returmn strings[i}: }

vclient 3",

Y
chrollPanel.setViewportView(jListl);

jList2.setModel (nev javax.swing.AbstractListModel() {
stringl] strings = { "ltem 17, "Item 2", "Item 37, "Item 4",
"Ttem 5" };
public int getSize{) { return strings.length; }
public Object getElementAt(int iy { return strings{il; }

Y
chrollPaneZ.setViewportView(jListZ);

jList3.setModel(new javax.swing.AbstractListModel() {
stringl] strings = { "Item 1", "Ttem 2", "Item 3", "Item a",
“Ttem 5" )i
public int getSize() { return strings.length; }
public Object getElementAt(int i} { return strings([il; }

b i
chrollPaneB.setViewportView(jList3};

jButtonl.setText("Kick");

jButtonZ.setText("Ban");

javax.swing.GroupLayout jInternalFrame4Layout = new
javax.swing.GroupLayout(jInternalFrame4.getContentPane());

jInternalFrameé.getContentPane{).setLayout(jInternalFrame4Layout);
jInternalFrameaLayout.setHorizontalGroup(
jinternalFrame4Layout.createParallelGroup(javax.swing.GroupLayout.Alignme

nt.LEADING)
.addGroup(jInternalFrame4Layout.createSequentialGroup()

.addContainerGap()

.addGroup(jInternalFramedLayout.createParallelGroup(javax.swing.GroupLayo

ut.Alignment.LEADING, false)
.addComponent(jLabelZ,

javax.swing.GroupLayout.PREFERRED_SIZE, 424,
javax.swing.GroupLayout.PREFERRED*SIZE)

.addGroup(jInternalFramedLayout.createSequentialGroup()
.addComponent(chrollPanel,
javax.swing.GroupLayout.PREFERRED_SIZE, 175,
javax.swing.GroupLayout.PREFERRED_SIZE)
.addGap (33, 33, 33)
.addComponent(chrollPaneZ,
javax.swing.GroupLayout.PREFERRED_SIZE, 65,
javax.swing.GroupLayout.PREFERRED_SIZE)

.addPreferredGap(javax.swing.LayoutStyle.ComponentPlacement.RELATED,
javax.swing.GroupLayout.DEFAULTﬁSIZE, Short .MAX VALUE)
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.addComponent(chrollPane3,
javax.swing.GroupLayout.PREFERRED_SIZE, 106,
javax.swing.GroupLayout.PREFERRED_SIZE))

.addGroup(jInternalFrame4Layout.createSequentialGroup()
.addComponent {jButtonl,
javax.swing.GroupLayout.PREFERRED_SIZE, 87,
‘javax.swing.GroupLayout.PREFERRED_SIZE)

.addPreferredGap(javax.swing.LayoutStyle.ComponentPlacement.RELATED)
.addComponent. (jButtonz,
javax.swing.GroupLayout.PREFERREDFSIZE, 20,
javax.swing.GroupLayout.PREFERRED_SIZE)))
.addContainerGap (70, Short.MAX VALUE))
)i
jInternalFrame4Layout.setVerticalGroup(

jInternalFrameﬁLayout.createParallelGroup(javax.swing.GroupLayout.Alignme

nt.LEADING)
.addGroup(jInternalFrame4Layout.createSequentialGroup()

.addContainerGap ()
.addComponent(jLabelZ)

.addPreferredGap(javax.swing.LayoutStyle.ComponentPlacement.UNRELATED)

.addGroup(jInternalFrame4Layout.createParallelGroup(javax.swing.GroupLayo
ut.Alignment . TRAILING)
.addComponent(chrollPanel,
javax.swing.GroupLayout.PREFERRED#SIZE,
javax.swing.GroupLayout.DEFAULT_SIZE,
javax.swing.GroupLayout.PREFERRED_SIZE)
.addComponent(chrollPanez,
javax.swing.GroupLayout.PREFERRED_SIZE,
javax.swing.GroupLayout.DEFAULTﬂSIZE,
javax.swing.GroupLayout.PREFERRED_SIZE)
.addComponent(chrollPaneB,
javax.swing.GroupLayout.PREFERRED_SIZE,
javax.swing.GroupLayout.DEFAULT_SIZE,
javax.swing.GroupLayout.PREFERRED_SIZE))

.addPreferredGap(javax.swing.LayoutStyle.ComponentPlacement.RELATED, 38,
Short.MAX_VALUE)

.addGroup{jInternalFrame4Layout.createParallelGroup(javax.swing.GroupLayo
ut .Alignment .BASELINE)
.addComponent {jButtonl)
.addComponent(jButton2))
.addContainerGap())

Y
jTabbedPanel.addTab(" Clients ", jInternalFrame4);

javax.swing.GroupLayout jInternalFrame5Layout = new
javax.swing.GroupLayout(jInternalFrameS.getContentPane());

jInternalFrame5.getContentPane().setLayout(jInternalFrameSLayout);
jInternalFrame5Layout.setHorizontalGroup(
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jInternalFrame5Layout.createParallelGroup(javax.swing.GroupLayout.Alignme
nt .LEADING)
.addGap (0, 504, Short.MAX VALUE)
)

jInternalFrameSLayout.setVerticalGroup(

7jInternalFrameSLayout.createParallelGroup(javax.swing.GroupLayout.Alignme
nt.LEADING)
.addGap (0, 238, Short.MAX VALUE)

)
jTabbedPanel.addTab(" Bans ", jInternalFramed);

javax.swing.GroupLayout jInternalFrame6Layout = new
javax.swing.GroupLayout(jInternalFrameG.getContentPane());

jInternalFrame6.getContentPane().setLayout(jInternalFrameGLayout);
jInternalFrame6Layout.setHorizontalGroup{

jInternalFrame6Layout.createParallelGroup(javax.swing.GroupLayout.Alignme
nt.LEADING)
,addGap (0, 504, Short .MAX VALUE)
)i
jInternalFrameGLayout.setVerticalGroup{

jInternalFrame6Layout.createParallelGroup{javax.swing.GroupLayout.Alignme
nt.LEADING)
.addGap (0, 238, Short .MAX_VALUE)

)i
jTabbedPanel.addTab(" Console ", jInternalFrame6);

javax.swing.GroupLayout layout = new
javax.swing.GroupLayout(getContentPane());

getContentPane(}.setLayout(layout);

layout.setHorizontalGroup(

layout.createParallelGroup(javax.swing.GroupLayout.Alignment.LEADING)
.addComponent (jLabell,
javax.swing.GroupLayout.Alignment.TRAILING,
javax.swing.GroupLayout.DEFAULT_SIZE, 539, Short.MAX VALUE)
.addComponent(jSeparatorl,
javax.swing.GroupLayout.DEFAULTESIZE, 539, Short.MAX VALUE)
.addGroup(layout.createSequentialGroup()
.addContainerGap ()
.addComponent(jTabbedPanel,
javax.swing.GroupLayout.DEFAULT_SIZE, 519, Short.MAX VALUE)
.addContainerGap () )
)i
layout.setVerticalGroup(

layout.createParallelGroup{javax.swing.GroupLayout.Alignment.LEADING)
.addGroup(layout.createSequentialGroup()
.addComponent (jLabkell,
javax.swing.GroupLayout.PREFERRED_SIZE, 64,
javax.swing.GroupLayout.PREFERRED‘SIZE)
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,addPreferredGap(javax.swing.LayoutStyle.ComponentPlacement.RELATED)
.addComponent(jSeparatorl,

javax.swing.GroupLayout.PREFERREDESIZE, 10,

javax.swing.GroupLayout.PREFERRED_SIZE)

,addPreferredGap(javax.swing.LayoutStyle.ComponentPlacement.UNRELATED)
.addComponent(jTabbedPanel,
javax.swing.GroupLayout.DEFAULT_SIZE, 301, Short.MAX#VALUE)
.addContainerGap())
)i

pack();
y// </editor—fold>//GEN—END:initComponents

// Variables declaration - do not modify//GEN—BEGIN:variables
private javax.swing.JButton jButtonl;

private javax.swing.JButton jButtonz;

private javax.swing.JInternalFrame jInternalFramel;
private javax.swing.JInternalFrame jInternalFrameZ;
private javax.swing.JInternalFrame jInternalFrame3;
private javax.swing.JInternalFrame jInternalFrame4;
private javax.swing.JInternalFrame jInternalFrameS;
private javax.swing.JInternalFrame jInternalFrame6;
private javax.swing.JLabel jLabell;

private javax.swing.JLabel jlabelZ;

private javax.swing.JList jListl;

private javax.swing.JList jList2;

private javax.swing.JList JList3;

private javax.swing.JScrollPane chrollPanel;
private javax.swing.JScrollPane chrollPaneZ;
private javax.swing.JScrollPane chrollPaneB;
private javax.swing.JSeparator jSeparatorl;

private javax.swing.JTabbedPane jTabbedPanel;

// End of variables declaration//GEN—END:variables




Chapter 5

5.1 Testing

Testing is the process of executing the program(s) with the intention of finding out errors. During
testing, the program to be tested is executed with a set of test cases and the output of the programs
for the test case is evaluated to determine if the program is performing as it is expected to be. The

success of testing in revealing errors in programs depends critically on the test cases

5.1.1 LEVELS OF TESTING

UNIT TESTING: The first level of testing is called unit testing. In this different modules are tested

against the specifications produced during design of the modules. Unit testing is essentially for
verification of the code produced during coding phase, and hence the goal is to test the internal

logic of the modules. The programmer of the module typically does it.

INTEGRATION TESTING: The next level of testing is often called integration testing. In this,

many unit-tested modules are combined into subsystems, which are then tested. The goal is here to
see if the modules can be integrated properly. Hence, the emphasis is on testing interfaces between
modules. The testing activity can be considered testing the design. The integration plan specifies the
steps and order in which modules are combined to realize the full system. After each integration
step, the partially integrated system is tested. An important factor that guides the integration is the
module dependency graph.

SYSTEM TESTING: System tests are designed to validate a fully developed system to assure that it

meets its requirements. There are essentially three main kinds of system testing:

ALPHA TESTING: Alpha refers to the system testing carried out by the test team within the

developing organization.

BETA TESTING: Beta testing is the system testing performed by a select group of friendly ;I

custometrs.
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ACCEPTANCE TESTING: Acceptance testing is the system testing performed by the customer to

determine whether to accept or reject the delivery of the system.

5.1.2 TYPES OF TESTING:

BLACK BOX TESTING: This testing is also known as functional testing. The basis for deciding
test cases in functional testing is the requirements or specifications of the system or modules. For
the entire system test cases are designed form the requirement specification document from the
system. There are number of techniques that can be used to select test cases that have been found to

be very successful in detecting errors.Some of them are:

Equivalence class partitioning: In this we divide the domain of all the inputs into a set of

equivalence classes. That is we want to identify classes of test cases such that the success of one test
case in a class implies the success of others. It is often useful to consider equivalence classes in the
output. For an output equivalence class, the goal is to generate test cases such that the output of that

test case lies in the output equivalence class.

Boundary value analysis: In boundary value analysis, we choose an input for a test case from an

equivalence class, such that the input lies at the edge of the equivalence class. Boundary value rest

cases are also called “extreme cases”.

Cause-effect graphing: It is a technique that aids in selecting combinations of input conditions in a
systematic way. A cause is a distinct input condition, and an effect is n distinct output condition.
Each condition forms a node in the cause-effect graph. Beyond generating high-yield test cases, it
also aids the understanding of the functionality of the system, because the tester must identify the

distinct causes and effects.
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Special cases: It depends on the data structures and the function of the module. There are no rules to
determine special cases, and the tester has to use his intuition and experience to identify such test

cases. Consequently, determining special cases is also called “error guessing.

WHITE BOX TESTING: There arc several white box-testing strategies. Each testing strategy is
based on some heuristic. One white box testing strategy is said to be stronger than another strategy,
if all types of errors detected by the first testing strategy (say B) are also detected by the second
testing strategy (say A), and the second strategy additionally detects some more types of errors.
When two testing strategies detect errors that are different at least with respect to some types of

errors, they are then called complementary.

Statement coverage: It aims to design test cases so that every statement in the program is executed

at least once. The principal idea is that unless we execute a statement, we have no way of

determining if error exists in that statement.

Branch coverage: In this strategy, test cases are designed to make each branch condition assume

true and false value in turn. It is also known as “edge-testing” as in this testing scheme, each edge

of a program’s control flow graph is traversed at least once.

Condition coverage: In this test cases are designed to make each component of a composite
conditional expression assume both truc and false values. Thus, condition testing is a stronger
testing strategy than branch testing. For conditional coverage, the number of test cases increases

exponentially with the number of component conditions.

Path coverage: It requires us to design test cases such that all linearly independent paths in the
program are executed at least once. These paths are defined in terms of control-flow graph of a

program.

As testing forms the first step towards determining the errors in a program it should be properly

carried out. , ‘
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UNIT TESTING:

Unit testing was carried out for each module against the specifications produced during the design

of the module.

Unit testing of each program and module was done with the following perception.

USER INTERFACE:

User interface was tested which gave rise to more user understandable errors and help messages.
INTERNAL LOGIC:

While testing a module, the internal logic was tested.

INTEGRATED TESTING:

Tint the integrated testing, the unit-tested modules were combined into subsystems and then tested.
The strategies for integrated tested comprised of

¢ Performance time testing.
e Logical cycle of data.
¢ Test data.

s Live data obtained from users.

5.1.3.3 Environments

The environment on which we have performed the firewall configuration and testing was a linux
workstation that has virtual network of virtual computers that are managed by the MLN tool. The
network schema is described in the lab document. The tests are done using external and internal

UML instances.
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CHAPTER 6

Conclusion:
The rules in this application can implement the following situations:

Text chat (peer to peer)

Text chat (peer to all) | Broadcast mode
Voice chat (peer to peer)

Voice chat (Broadcast mode)

Server failure support

Centralised server

UL RN

Future Recommendations:
v" The same can be implemented on a cloud based approach.
v Distributed server can be implemented instead of centralised server.
v Video chat can be implemented.
v" Implementing functionality to allow user input of the search keyword.

v' File transfer can be done using the same server and client architecture
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